映射外网_nat123论坛客服

 找回密码
 获得新生
查看: 19623|回复: 65

通过nat123动态域名解析HTTP版在软路由中编写脚本自动获取公网IP

  [复制链接]
发表于 2014-8-21 09:15:49 | 显示全部楼层 |阅读模式
nat123发布了“动态域名解析HTTP版”,我们可以利用这个功能,通过软路由等设备直接获取公网IP,不用再运行nat123客户端,方便了很多,现把方法分享给大家。下面以routeros软路由为例说明。
在Winbox中,“System”的“Scripts”下,增加一段脚本

local ipaddr

local server "http://ddns.nat123.com"

local domain "domain"     '注释  nat123解析的动态域名

local par "/update.jsp?hostname=$domain&myip=$ipaddr"

local users "username"    '注释  nat123的用户名

local paswd "password"    '注释  nat123的密码

:set ipaddr [/ip address get [/ip address find interface=pppoe-out1] address]

:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]

/tool fetch url=($server . $par) mode=http user=$users password=$paswd







完成后在在“System”的“Scheduler”下增加一个任务来触发上面的脚本
三分钟触发一次



本方法在自己的软路由上以实现。







本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?获得新生

x
发表于 2014-8-21 09:41:06 | 显示全部楼层

技术活呀,不错,不错。顶一个。要是分享在站外,就可以得T币了
 楼主| 发表于 2014-8-21 09:57:36 | 显示全部楼层
谢谢提醒!!准备准备
发表于 2014-8-23 12:03:14 | 显示全部楼层
学习啦啦啦。。。
发表于 2014-8-24 11:08:16 | 显示全部楼层
不错不错
发表于 2014-8-26 12:03:37 | 显示全部楼层
支持
发表于 2014-8-26 14:01:17 | 显示全部楼层
111
发表于 2014-8-26 14:01:32 | 显示全部楼层
111111111111
发表于 2014-8-26 14:01:49 | 显示全部楼层
ewrwerate
发表于 2014-9-4 16:20:31 | 显示全部楼层
技术活!
您需要登录后才可以回帖 登录 | 获得新生

本版积分规则

手机版|nat123  

GMT+8, 2018-2-23 06:05 , Processed in 0.192641 second(s), 20 queries .

Powered by Discuz! X3.1

© 2001-2013 Comsenz Inc. | 网站反馈邮箱:natbbs#163.com(把#换成@)

快速回复 返回顶部 返回列表